За да инсталирате на Google Chrome Browser на Ubuntu 9.04 операционна система е необходимо да се изпълни следната кратка последователност:

Редактирайте файла /etc/apt/sources.list използвайки командата:

sudo gedit /etc/apt/sources.list

Вътре добавете следните два реда:

deb http://ppa.launchpad.net/chromium-daily/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/chromium-daily/ppa/ubuntu jaunty main

Запишете и излезте от файла.

Сега добавете GPG ключ използвайки следната команда:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0xfbef0d696de1c72ba5a835fe5a9bf3bb4e5e17b5

Актуализирайте списъка с източници за актуализация с командата:

sudo apt-get update

И сега можете елегантно да инсталирате браузера с команда:

sudo apt-get install chromium-browser

С това инсталацията е завършена.
Можете да стартирате програмата от Applications->CrossOver Chromium->Chromium

Ето резултата от изпълнението на посочените команди на моята машина:

mitko@bsu-room-417:~$ sudo gedit /etc/apt/sources.list
mitko@bsu-room-417:~$ sudo apt-key adv –recv-keys –keyserver keyserver.ubuntu.com 0xfbef0d696de1c72ba5a835fe5a9bf3bb4e5e17b5
Executing: gpg –ignore-time-conflict –no-options –no-default-keyring –secret-keyring /etc/apt/secring.gpg –trustdb-name /etc/apt/trustdb.gpg –keyring /etc/apt/trusted.gpg –recv-keys –keyserver keyserver.ubuntu.com 0xfbef0d696de1c72ba5a835fe5a9bf3bb4e5e17b5
gpg: requesting key 4E5E17B5 from hkp server keyserver.ubuntu.com
gpg: key 4E5E17B5: public key “Launchpad PPA for chromium-daily” imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
mitko@bsu-room-417:~$ sudo apt-get update
Hit http://bg.archive.ubuntu.com jaunty Release.gpg
Ign http://bg.archive.ubuntu.com jaunty/main Translation-en_US
Ign http://bg.archive.ubuntu.com jaunty/restricted Translation-en_US
Ign http://bg.archive.ubuntu.com jaunty/universe Translation-en_US
Ign http://bg.archive.ubuntu.com jaunty/multiverse Translation-en_US
Hit http://bg.archive.ubuntu.com jaunty-updates Release.gpg
Ign http://bg.archive.ubuntu.com jaunty-updates/main Translation-en_US
Ign http://bg.archive.ubuntu.com jaunty-updates/restricted Translation-en_US
Ign http://bg.archive.ubuntu.com jaunty-updates/universe Translation-en_US
Ign http://bg.archive.ubuntu.com jaunty-updates/multiverse Translation-en_US
Hit http://bg.archive.ubuntu.com jaunty Release
Hit http://bg.archive.ubuntu.com jaunty-updates Release
Hit http://bg.archive.ubuntu.com jaunty/main Packages
Hit http://bg.archive.ubuntu.com jaunty/restricted Packages
Hit http://bg.archive.ubuntu.com jaunty/main Sources
Hit http://bg.archive.ubuntu.com jaunty/restricted Sources
Hit http://bg.archive.ubuntu.com jaunty/universe Packages
Hit http://bg.archive.ubuntu.com jaunty/universe Sources
Hit http://bg.archive.ubuntu.com jaunty/multiverse Packages
Hit http://bg.archive.ubuntu.com jaunty/multiverse Sources
Hit http://security.ubuntu.com jaunty-security Release.gpg
Ign http://security.ubuntu.com jaunty-security/main Translation-en_US
Hit http://bg.archive.ubuntu.com jaunty-updates/main Packages
Hit http://bg.archive.ubuntu.com jaunty-updates/restricted Packages
Hit http://bg.archive.ubuntu.com jaunty-updates/main Sources
Hit http://bg.archive.ubuntu.com jaunty-updates/restricted Sources
Hit http://bg.archive.ubuntu.com jaunty-updates/universe Packages
Hit http://bg.archive.ubuntu.com jaunty-updates/universe Sources
Hit http://bg.archive.ubuntu.com jaunty-updates/multiverse Packages
Hit http://bg.archive.ubuntu.com jaunty-updates/multiverse Sources
Get:1 http://ppa.launchpad.net jaunty Release.gpg [307B]
Ign http://ppa.launchpad.net jaunty/main Translation-en_US
Ign http://security.ubuntu.com jaunty-security/restricted Translation-en_US
Ign http://security.ubuntu.com jaunty-security/universe Translation-en_US
Ign http://security.ubuntu.com jaunty-security/multiverse Translation-en_US
Hit http://security.ubuntu.com jaunty-security Release
Get:2 http://ppa.launchpad.net jaunty Release [74.7kB]
Hit http://security.ubuntu.com jaunty-security/main Packages
Hit http://security.ubuntu.com jaunty-security/restricted Packages
Hit http://security.ubuntu.com jaunty-security/main Sources
Hit http://security.ubuntu.com jaunty-security/restricted Sources
Hit http://security.ubuntu.com jaunty-security/universe Packages
Hit http://security.ubuntu.com jaunty-security/universe Sources
Hit http://security.ubuntu.com jaunty-security/multiverse Packages
Hit http://security.ubuntu.com jaunty-security/multiverse Sources
Get:3 http://ppa.launchpad.net jaunty/main Packages [3232B]
Get:4 http://ppa.launchpad.net jaunty/main Sources [1496B]
Fetched 79.7kB in 3s (24.1kB/s)
Reading package lists… Done
mitko@bsu-room-417:~$ sudo apt-get install chromium-browser
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
linux-headers-2.6.28-11 linux-headers-2.6.28-11-generic
Use ‘apt-get autoremove’ to remove them.
The following extra packages will be installed:
chromium-codecs-ffmpeg
Suggested packages:
chromium-browser-l10n
The following NEW packages will be installed:
chromium-browser chromium-codecs-ffmpeg
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 12.8MB of archives.
After this operation, 31.4MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ppa.launchpad.net jaunty/main chromium-codecs-ffmpeg 0.5+svn20090828r24798-0ubuntu1~ucd1~jaunty [384kB]
Get:2 http://ppa.launchpad.net jaunty/main chromium-browser 4.0.204.0~svn20090831r24879-0ubuntu1~ucd1~jaunty [12.4MB]
Fetched 12.8MB in 35s (358kB/s)
Selecting previously deselected package chromium-codecs-ffmpeg.
(Reading database … 121247 files and directories currently installed.)
Unpacking chromium-codecs-ffmpeg (from …/chromium-codecs-ffmpeg_0.5+svn20090828r24798-0ubuntu1~ucd1~jaunty_i386.deb) …
Selecting previously deselected package chromium-browser.
Unpacking chromium-browser (from …/chromium-browser_4.0.204.0~svn20090831r24879-0ubuntu1~ucd1~jaunty_i386.deb) …
Processing triggers for man-db …
Setting up chromium-browser (4.0.204.0~svn20090831r24879-0ubuntu1~ucd1~jaunty) …

Setting up chromium-codecs-ffmpeg (0.5+svn20090828r24798-0ubuntu1~ucd1~jaunty) …

Processing triggers for libc6 …
ldconfig deferred processing now taking place
mitko@bsu-room-417:~$

Published by Димитър Минчев

Доктор по информатика и компютърни науки